epiphany Build Log

module epiphany will be built even though WebKit failed 2018-08-09 04:16:12.052
module epiphany will be built even though glib failed 2018-08-09 04:16:12.052
Checking out epiphany 2018-08-09 04:16:12.052
git remote set-url origin https://git.gnome.org/browse/epiphany
git remote update origin
Fetching origin
warning: redirecting to https://gitlab.gnome.org/GNOME/epiphany.git/
From https://git.gnome.org/browse/epiphany
   f5815e88a..196d3a5e2  master     -> origin/master
git rebase origin/master
First, rewinding head to replay your work on top of it...
Fast-forwarded master to origin/master.
Configuring epiphany 2018-08-09 04:16:40.726
meson --prefix /home/lantw44/gnome/devinstall --libdir lib  --buildtype=debug -Dgtk_doc=true -Dman=true -Dbuild_man=true -Ddisable_gtkdoc=false -Ddocbook=true -Ddocs=true -Ddocumentation=true -Denable-doc=true -Denable-gtk-doc=true -Denable-man=true -Denable_docs=true -Denable_gtk_doc=true -Denable_valadoc=true -Dgtk-doc=true -Dman-pages=true -Dmanpage=true -Dwith_docs=true  /home/lantw44/gnome/source/epiphany
The Meson build system
Version: 0.47.1
Source dir: /home/lantw44/gnome/source/epiphany
Build dir: /home/lantw44/gnome/build/epiphany
Build type: native build
WARNING: Unknown options: "build_man, disable_gtkdoc, docbook, docs, documentation, enable-doc, enable-gtk-doc, enable-man, enable_docs, enable_gtk_doc, enable_valadoc, gtk-doc, gtk_doc, man, man-pages, manpage, with_docs"
Project name: epiphany
Project version: 3.29.90
Appending CFLAGS from environment: '-Wno-error=format-nonliteral'
Appending LDFLAGS from environment: '-L/home/lantw44/gnome/devinstall/lib -L/usr/local/lib '
Native C compiler: clang -std=c11 (clang 6.0.0 "FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0)")
Build machine cpu family: x86_64
Build machine cpu: x86_64
Found pkg-config: /usr/local/bin/pkg-config (1.4.2)
Native dependency iso-codes found: YES 3.76
Configuring config.h using configuration
Configuring ephy-vcs-version.h using configuration
Native dependency cairo found: YES 1.15.13
Native dependency libdazzle-1.0 found: YES 3.29.4
Native dependency gcr-3 found: YES 3.28.0
Native dependency gdk-3.0 found: YES 3.23.2
Native dependency gdk-pixbuf-2.0 found: YES 2.37.1
Native dependency gio-2.0 found: YES 2.57.1
Native dependency gio-unix-2.0 found: YES 2.57.1
Native dependency glib-2.0 found: YES 2.57.1
Native dependency gtk+-3.0 found: YES 3.23.2
Native dependency gtk+-unix-print-3.0 found: YES 3.23.2
Native dependency hogweed found: YES 3.4
Native dependency icu-uc found: YES 62.1
Native dependency json-glib-1.0 found: YES 1.5.1
Native dependency libnotify found: YES 0.7.7
Native dependency libsecret-1 found: YES 0.18.6
Native dependency libsoup-2.4 found: YES 2.63.2
Native dependency libxml-2.0 found: YES 2.9.7
Native dependency libxslt found: YES 1.1.32
Native dependency nettle found: YES 3.4
Native dependency sqlite3 found: YES 3.24.0
Native dependency webkit2gtk-4.0 found: NO found '2.21.4' but need: '>= 2.21.5'

meson.build:93:0: ERROR:  Invalid version of dependency, need 'webkit2gtk-4.0' ['>= 2.21.5'] found '2.21.4'.

A full log can be found at /home/lantw44/gnome/build/epiphany/meson-logs/meson-log.txt
error during stage configure of epiphany: Error running meson --prefix /home/lantw44/gnome/devinstall --libdir lib --buildtype=debug -Dgtk_doc=true -Dman=true -Dbuild_man=true -Ddisable_gtkdoc=false -Ddocbook=true -Ddocs=true -Ddocumentation=true -Denable-doc=true -Denable-gtk-doc=true -Denable-man=true -Denable_docs=true -Denable_gtk_doc=true -Denable_valadoc=true -Dgtk-doc=true -Dman-pages=true -Dmanpage=true -Dwith_docs=true /home/lantw44/gnome/source/epiphany 2018-08-09 04:16:41.883
The Gnome Live! website may have suggestions on how to resolve some build errors. Visit http://live.gnome.org/JhbuildIssues/epiphany for more information.
Failed 2018-08-09 04:16:41.883